Удалить пакет и его зависимости в CentOS 7

По каким-то причинам вы захотели удалить пакет, но вместе с ним были установлены десятки зависимостей. yum erase <пакет> удалит только пакет, но не зависимости. Как быть?

Всё очень просто. Удалить пакет и все зависимости, с которыми он был установлен, можно с помощью команды yum history.

Допустим мы установили пакет pgadmin4, который притянул к себе десятки зависимостей и нам надо его удалить.

1. Введите yum history, чтобы посмотреть историю установок пакетов с помощью yum install:

yum history
Loaded plugins: fastestmirror
ID     | Command line             | Date and time    | Action(s)      | Altered
-------------------------------------------------------------------------------
    30 | erase pgadmin4           | 2019-11-21 15:14 | Erase          |    1
    29 | install pgadmin4         | 2019-11-21 15:06 | Install        |   54
    28 | install mod_wsgi         | 2019-11-21 14:48 | Install        |    1
    27 | install postfix          | 2019-11-17 18:12 | Install        |    1
    26 | install install socat    | 2019-11-14 13:25 | Install        |    1
    25 | install -y sshfs         | 2019-11-13 17:49 | Install        |    3
    24 | install tree             | 2019-11-13 17:38 | Install        |    1
    23 | install unzip            | 2019-11-12 17:38 | Install        |    1
    22 | install zip              | 2019-11-12 17:36 | Install        |    1
    21 | install git              | 2019-11-12 15:39 | Install        |   31
    20 | install nmap             | 2019-11-12 13:32 | Install        |    2
    19 | install tcpdump          | 2019-11-12 11:26 | Install        |    2
    18 | install zabbix-get       | 2019-11-12 10:08 | Install        |    1
    17 | install certbot python2- | 2019-11-11 19:47 | Install        |   31
    16 | install php-mcrypt       | 2019-11-11 18:53 | Install        |    2
    15 | install epel-release     | 2019-11-11 18:52 | Install        |    1
    14 | -y install wget          | 2019-11-11 17:07 | Install        |    1
    13 | install firewalld        | 2019-11-10 17:04 | Install        |    8
    12 | erase iptables-services  | 2019-11-10 17:04 | Erase          |    1
    11 | install iptables-service | 2019-11-10 17:02 | Install        |    1
history list


Видим, что был установлен pgadmin4 под номером 29.

2. Введите yum history undo 29, чтобы отменить установку пакета и всех установленным вместе с ним зависимостей:
 

yum history undo 29
Loaded plugins: fastestmirror
Undoing transaction 29, from Thu Nov 21 15:06:54 2019
    Dep-Install libtomcrypt-1.17-26.el7.x86_64                          @extras
    Dep-Install libtommath-0.42.0-6.el7.x86_64                          @extras
    Install     pgadmin4-4.13-1.rhel7.x86_64                            @pgdg10
    Dep-Install pgadmin4-docs-4.13-1.rhel7.noarch                       @pgdg10
    Dep-Install pgadmin4-python-Flask-Mail-0.9.1-4.rhel7.1.noarch       @pgdg10
    Dep-Install pgadmin4-python-alembic-0.9.7-3.rhel7.1.noarch          @pgdg10
    Dep-Install pgadmin4-python-babel-2.3.4-2.rhel7.1.noarch            @pgdg10
    Dep-Install pgadmin4-python-backports.csv-1:1.0.5-3.rhel7.1.noarch  @pgdg10
    Dep-Install pgadmin4-python-beautifulsoup4-4.5.1-3.rhel7.1.noarch   @pgdg10
    Dep-Install pgadmin4-python-blinker-1.4-3.rhel7.1.noarch            @pgdg10
    Dep-Install pgadmin4-python-dateutil-1:2.7.2-1.rhel7.1.noarch       @pgdg10
    Dep-Install pgadmin4-python-flask-1:1.0.2-1.rhel7.noarch            @pgdg10
    Dep-Install pgadmin4-python-flask-babel-0.11.1-4.rhel7.1.noarch     @pgdg10
    Dep-Install pgadmin4-python-flask-babelex-0.9.3-1.rhel7.1.noarch    @pgdg10
    Dep-Install pgadmin4-python-flask-gravatar-0.5.0-1.rhel7.1.noarch   @pgdg10
    Dep-Install pgadmin4-python-flask-htmlmin-1.5.0-1.rhel7.noarch      @pgdg10
    Dep-Install pgadmin4-python-flask-login-0.4.1-1.rhel7.noarch        @pgdg10
    Dep-Install pgadmin4-python-flask-migrate-2.4.0-1.rhel7.noarch      @pgdg10
    Dep-Install pgadmin4-python-flask-paranoid-0.2-1.rhel7.1.noarch     @pgdg10
    Dep-Install pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch @pgdg10
    Dep-Install pgadmin4-python-flask-security-3.0.0-1.rhel7.1.noarch   @pgdg10
    Dep-Install pgadmin4-python-flask-sqlalchemy-2.3.2-1.rhel7.noarch   @pgdg10
    Dep-Install pgadmin4-python-flask-wtf-0.14.2-1.rhel7.noarch         @pgdg10
    Dep-Install pgadmin4-python-htmlmin-0.1.12-1.rhel7.1.noarch         @pgdg10
    Dep-Install pgadmin4-python-itsdangerous-0.24-10.rhel7.1.noarch     @pgdg10
    Dep-Install pgadmin4-python-jinja2-2.8-9.rhel7.1.noarch             @pgdg10
    Dep-Install pgadmin4-python-markupsafe-0.23-13.rhel7.1.x86_64       @pgdg10
    Dep-Install pgadmin4-python-passlib-1.7.1-1.rhel7.1.noarch          @pgdg10
    Dep-Install pgadmin4-python-psutil-5.5.1-1.rhel7.x86_64             @pgdg10
    Dep-Install pgadmin4-python-simplejson-3.16.0-1.rhel7.x86_64        @pgdg10
    Dep-Install pgadmin4-python-six-1.12.0-3.rhel7.noarch               @pgdg10
    Dep-Install pgadmin4-python-sqlalchemy-1.2.18-1.rhel7.x86_64        @pgdg10
    Dep-Install pgadmin4-python-sqlparse-0.2.4-1.rhel7.1.noarch         @pgdg10
    Dep-Install pgadmin4-python-sshtunnel-0.1.4-1.rhel7.noarch          @pgdg10
    Dep-Install pgadmin4-python-werkzeug-0.15.4-1.rhel7.noarch          @pgdg10
    Dep-Install pgadmin4-python-wtforms-2.2.1-1.rhel7.noarch            @pgdg10
    Dep-Install pgadmin4-pytz-2018.9-1.rhel7.noarch                     @pgdg10
    Dep-Install pgadmin4-web-4.13-1.rhel7.noarch                        @pgdg10
    Dep-Install python-beaker-1.5.4-10.el7.noarch                       @base
    Dep-Install python-blinker-1.3-2.el7.noarch                         @extras
    Dep-Install python-dateutil-1.5-7.el7.noarch                        @base
    Dep-Install python-editor-0.4-4.el7.noarch                          @epel
    Dep-Install python-flask-1:0.10.1-4.el7.noarch                      @extras
    Dep-Install python-itsdangerous-0.23-2.el7.noarch                   @extras
    Dep-Install python-lxml-3.2.1-4.el7.x86_64                          @base
    Dep-Install python-mako-0.8.1-2.el7.noarch                          @base
    Dep-Install python-paramiko-2.1.1-9.el7.noarch                      @base
    Dep-Install python-paste-1.7.5.1-9.20111221hg1498.el7.noarch        @base
    Dep-Install python-speaklater-1.3-1.el7.noarch                      @epel
    Dep-Install python-tempita-0.5.1-6.el7.noarch                       @base
    Dep-Install python-werkzeug-0.11.11-2.rhel7.noarch                  @pgdg94
    Dep-Install python2-click-6.7-8.el7.noarch                          @epel
    Dep-Install python2-crypto-2.6.1-16.el7.x86_64                      @epel
    Dep-Install python2-psycopg2-2.8.3-3.rhel7.x86_64                   @pgdg10
No package matched to remove: pgadmin4-0:4.13-1.rhel7
Resolving Dependencies
--> Running transaction check
---> Package libtomcrypt.x86_64 0:1.17-26.el7 will be erased
---> Package libtommath.x86_64 0:0.42.0-6.el7 will be erased
---> Package pgadmin4-docs.noarch 0:4.13-1.rhel7 will be erased
---> Package pgadmin4-python-Flask-Mail.noarch 0:0.9.1-4.rhel7.1 will be erased
---> Package pgadmin4-python-alembic.noarch 0:0.9.7-3.rhel7.1 will be erased
---> Package pgadmin4-python-babel.noarch 0:2.3.4-2.rhel7.1 will be erased
---> Package pgadmin4-python-backports.csv.noarch 1:1.0.5-3.rhel7.1 will be erased
---> Package pgadmin4-python-beautifulsoup4.noarch 0:4.5.1-3.rhel7.1 will be erased
---> Package pgadmin4-python-blinker.noarch 0:1.4-3.rhel7.1 will be erased
---> Package pgadmin4-python-dateutil.noarch 1:2.7.2-1.rhel7.1 will be erased
---> Package pgadmin4-python-flask.noarch 1:1.0.2-1.rhel7 will be erased
---> Package pgadmin4-python-flask-babel.noarch 0:0.11.1-4.rhel7.1 will be erased
---> Package pgadmin4-python-flask-babelex.noarch 0:0.9.3-1.rhel7.1 will be erased
---> Package pgadmin4-python-flask-gravatar.noarch 0:0.5.0-1.rhel7.1 will be erased
---> Package pgadmin4-python-flask-htmlmin.noarch 0:1.5.0-1.rhel7 will be erased
---> Package pgadmin4-python-flask-login.noarch 0:0.4.1-1.rhel7 will be erased
---> Package pgadmin4-python-flask-migrate.noarch 0:2.4.0-1.rhel7 will be erased
---> Package pgadmin4-python-flask-paranoid.noarch 0:0.2-1.rhel7.1 will be erased
---> Package pgadmin4-python-flask-principal.noarch 0:0.4.0-14.rhel7.1 will be erased
---> Package pgadmin4-python-flask-security.noarch 0:3.0.0-1.rhel7.1 will be erased
---> Package pgadmin4-python-flask-sqlalchemy.noarch 0:2.3.2-1.rhel7 will be erased
---> Package pgadmin4-python-flask-wtf.noarch 0:0.14.2-1.rhel7 will be erased
---> Package pgadmin4-python-htmlmin.noarch 0:0.1.12-1.rhel7.1 will be erased
---> Package pgadmin4-python-itsdangerous.noarch 0:0.24-10.rhel7.1 will be erased
---> Package pgadmin4-python-jinja2.noarch 0:2.8-9.rhel7.1 will be erased
---> Package pgadmin4-python-markupsafe.x86_64 0:0.23-13.rhel7.1 will be erased
---> Package pgadmin4-python-passlib.noarch 0:1.7.1-1.rhel7.1 will be erased
---> Package pgadmin4-python-psutil.x86_64 0:5.5.1-1.rhel7 will be erased
---> Package pgadmin4-python-simplejson.x86_64 0:3.16.0-1.rhel7 will be erased
---> Package pgadmin4-python-six.noarch 0:1.12.0-3.rhel7 will be erased
---> Package pgadmin4-python-sqlalchemy.x86_64 0:1.2.18-1.rhel7 will be erased
---> Package pgadmin4-python-sqlparse.noarch 0:0.2.4-1.rhel7.1 will be erased
---> Package pgadmin4-python-sshtunnel.noarch 0:0.1.4-1.rhel7 will be erased
---> Package pgadmin4-python-werkzeug.noarch 0:0.15.4-1.rhel7 will be erased
---> Package pgadmin4-python-wtforms.noarch 0:2.2.1-1.rhel7 will be erased
---> Package pgadmin4-pytz.noarch 0:2018.9-1.rhel7 will be erased
---> Package pgadmin4-web.noarch 0:4.13-1.rhel7 will be erased
---> Package python-beaker.noarch 0:1.5.4-10.el7 will be erased
---> Package python-blinker.noarch 0:1.3-2.el7 will be erased
---> Package python-dateutil.noarch 0:1.5-7.el7 will be erased
---> Package python-editor.noarch 0:0.4-4.el7 will be erased
---> Package python-flask.noarch 1:0.10.1-4.el7 will be erased
---> Package python-itsdangerous.noarch 0:0.23-2.el7 will be erased
---> Package python-lxml.x86_64 0:3.2.1-4.el7 will be erased
---> Package python-mako.noarch 0:0.8.1-2.el7 will be erased
---> Package python-paramiko.noarch 0:2.1.1-9.el7 will be erased
---> Package python-paste.noarch 0:1.7.5.1-9.20111221hg1498.el7 will be erased
---> Package python-speaklater.noarch 0:1.3-1.el7 will be erased
---> Package python-tempita.noarch 0:0.5.1-6.el7 will be erased
---> Package python-werkzeug.noarch 0:0.11.11-2.rhel7 will be erased
---> Package python2-click.noarch 0:6.7-8.el7 will be erased
---> Package python2-crypto.x86_64 0:2.6.1-16.el7 will be erased
---> Package python2-psycopg2.x86_64 0:2.8.3-3.rhel7 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================================================
 Package                                                    Arch                             Version                                                 Repository                         Size
=============================================================================================================================================================================================
Removing:
 libtomcrypt                                                x86_64                           1.17-26.el7                                             @extras                           562 k
 libtommath                                                 x86_64                           0.42.0-6.el7                                            @extras                            69 k
 pgadmin4-docs                                              noarch                           4.13-1.rhel7                                            @pgdg10                            39 M
 pgadmin4-python-Flask-Mail                                 noarch                           0.9.1-4.rhel7.1                                         @pgdg10                            61 k
 pgadmin4-python-alembic                                    noarch                           0.9.7-3.rhel7.1                                         @pgdg10                           1.4 M
 pgadmin4-python-babel                                      noarch                           2.3.4-2.rhel7.1                                         @pgdg10                            20 M
 pgadmin4-python-backports.csv                              noarch                           1:1.0.5-3.rhel7.1                                       @pgdg10                           109 k
 pgadmin4-python-beautifulsoup4                             noarch                           4.5.1-3.rhel7.1                                         @pgdg10                           746 k
 pgadmin4-python-blinker                                    noarch                           1.4-3.rhel7.1                                           @pgdg10                           385 k
 pgadmin4-python-dateutil                                   noarch                           1:2.7.2-1.rhel7.1                                       @pgdg10                           717 k
 pgadmin4-python-flask                                      noarch                           1:1.0.2-1.rhel7                                         @pgdg10                           782 k
 pgadmin4-python-flask-babel                                noarch                           0.11.1-4.rhel7.1                                        @pgdg10                           122 k
 pgadmin4-python-flask-babelex                              noarch                           0.9.3-1.rhel7.1                                         @pgdg10                            76 k
 pgadmin4-python-flask-gravatar                             noarch                           0.5.0-1.rhel7.1                                         @pgdg10                            22 k
 pgadmin4-python-flask-htmlmin                              noarch                           1.5.0-1.rhel7                                           @pgdg10                           8.6 k
 pgadmin4-python-flask-login                                noarch                           0.4.1-1.rhel7                                           @pgdg10                            87 k
 pgadmin4-python-flask-migrate                              noarch                           2.4.0-1.rhel7                                           @pgdg10                            75 k
 pgadmin4-python-flask-paranoid                             noarch                           0.2-1.rhel7.1                                           @pgdg10                            13 k
 pgadmin4-python-flask-principal                            noarch                           0.4.0-14.rhel7.1                                        @pgdg10                            34 k
 pgadmin4-python-flask-security                             noarch                           3.0.0-1.rhel7.1                                         @pgdg10                           328 k
 pgadmin4-python-flask-sqlalchemy                           noarch                           2.3.2-1.rhel7                                           @pgdg10                           251 k
 pgadmin4-python-flask-wtf                                  noarch                           0.14.2-1.rhel7                                          @pgdg10                           127 k
 pgadmin4-python-htmlmin                                    noarch                           0.1.12-1.rhel7.1                                        @pgdg10                           142 k
 pgadmin4-python-itsdangerous                               noarch                           0.24-10.rhel7.1                                         @pgdg10                           105 k
 pgadmin4-python-jinja2                                     noarch                           2.8-9.rhel7.1                                           @pgdg10                           2.5 M
 pgadmin4-python-markupsafe                                 x86_64                           0.23-13.rhel7.1                                         @pgdg10                            85 k
 pgadmin4-python-passlib                                    noarch                           1.7.1-1.rhel7.1                                         @pgdg10                           4.1 M
 pgadmin4-python-psutil                                     x86_64                           5.5.1-1.rhel7                                           @pgdg10                           3.9 M
 pgadmin4-python-simplejson                                 x86_64                           3.16.0-1.rhel7                                          @pgdg10                           718 k
 pgadmin4-python-six                                        noarch                           1.12.0-3.rhel7                                          @pgdg10                           107 k
 pgadmin4-python-sqlalchemy                                 x86_64                           1.2.18-1.rhel7                                          @pgdg10                            30 M
 pgadmin4-python-sqlparse                                   noarch                           0.2.4-1.rhel7.1                                         @pgdg10                           271 k
 pgadmin4-python-sshtunnel                                  noarch                           0.1.4-1.rhel7                                           @pgdg10                           199 k
 pgadmin4-python-werkzeug                                   noarch                           0.15.4-1.rhel7                                          @pgdg10                           2.2 M
 pgadmin4-python-wtforms                                    noarch                           2.2.1-1.rhel7                                           @pgdg10                           806 k
 pgadmin4-pytz                                              noarch                           2018.9-1.rhel7                                          @pgdg10                           222 k
 pgadmin4-web                                               noarch                           4.13-1.rhel7                                            @pgdg10                            25 M
 python-beaker                                              noarch                           1.5.4-10.el7                                            @base                             281 k
 python-blinker                                             noarch                           1.3-2.el7                                               @extras                           358 k
 python-dateutil                                            noarch                           1.5-7.el7                                               @base                             343 k
 python-editor                                              noarch                           0.4-4.el7                                               @epel                              19 k
 python-flask                                               noarch                           1:0.10.1-4.el7                                          @extras                           1.1 M
 python-itsdangerous                                        noarch                           0.23-2.el7                                              @extras                            99 k
 python-lxml                                                x86_64                           3.2.1-4.el7                                             @base                             2.6 M
 python-mako                                                noarch                           0.8.1-2.el7                                             @base                             1.4 M
 python-paramiko                                            noarch                           2.1.1-9.el7                                             @base                             1.2 M
 python-paste                                               noarch                           1.7.5.1-9.20111221hg1498.el7                            @base                             3.2 M
 python-speaklater                                          noarch                           1.3-1.el7                                               @epel                              21 k
 python-tempita                                             noarch                           0.5.1-6.el7                                             @base                             128 k
 python-werkzeug                                            noarch                           0.11.11-2.rhel7                                         @pgdg94                           2.1 M
 python2-click                                              noarch                           6.7-8.el7                                               @epel                             567 k
 python2-crypto                                             x86_64                           2.6.1-16.el7                                            @epel                             2.2 M
 python2-psycopg2                                           x86_64                           2.8.3-3.rhel7                                           @pgdg10                           603 k
Not installed:
 pgadmin4                                                   x86_64                           4.13-1.rhel7                                            -                                 0.0

Transaction Summary
=============================================================================================================================================================================================
Remove         53 Packages
Not installed   1 Package

Installed size: 150 M
Is this ok [y/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Erasing    : pgadmin4-web-4.13-1.rhel7.noarch                                                                                                                                         1/53
  Erasing    : pgadmin4-python-flask-babel-0.11.1-4.rhel7.1.noarch                                                                                                                      2/53
  Erasing    : pgadmin4-python-flask-babelex-0.9.3-1.rhel7.1.noarch                                                                                                                     3/53
  Erasing    : pgadmin4-python-alembic-0.9.7-3.rhel7.1.noarch                                                                                                                           4/53
  Erasing    : pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch                                                                                                                  5/53
  Erasing    : 1:python-flask-0.10.1-4.el7.noarch                                                                                                                                       6/53
  Erasing    : python-mako-0.8.1-2.el7.noarch                                                                                                                                           7/53
  Erasing    : python-beaker-1.5.4-10.el7.noarch                                                                                                                                        8/53
  Erasing    : python-paste-1.7.5.1-9.20111221hg1498.el7.noarch                                                                                                                         9/53
  Erasing    : pgadmin4-python-beautifulsoup4-4.5.1-3.rhel7.1.noarch                                                                                                                   10/53
  Erasing    : pgadmin4-python-flask-gravatar-0.5.0-1.rhel7.1.noarch                                                                                                                   11/53
  Erasing    : pgadmin4-python-flask-htmlmin-1.5.0-1.rhel7.noarch                                                                                                                      12/53
  Erasing    : pgadmin4-python-flask-login-0.4.1-1.rhel7.noarch                                                                                                                        13/53
  Erasing    : pgadmin4-python-flask-migrate-2.4.0-1.rhel7.noarch                                                                                                                      14/53
  Erasing    : 1:pgadmin4-python-flask-1.0.2-1.rhel7.noarch                                                                                                                            15/53
  Erasing    : pgadmin4-python-sshtunnel-0.1.4-1.rhel7.noarch                                                                                                                          16/53
  Erasing    : python2-crypto-2.6.1-16.el7.x86_64                                                                                                                                      17/53
  Erasing    : python-paramiko-2.1.1-9.el7.noarch                                                                                                                                      18/53
  Erasing    : pgadmin4-python-itsdangerous-0.24-10.rhel7.1.noarch                                                                                                                     19/53
  Erasing    : pgadmin4-python-jinja2-2.8-9.rhel7.1.noarch                                                                                                                             20/53
  Erasing    : pgadmin4-python-werkzeug-0.15.4-1.rhel7.noarch                                                                                                                          21/53
  Erasing    : python2-click-6.7-8.el7.noarch                                                                                                                                          22/53
  Erasing    : pgadmin4-python-htmlmin-0.1.12-1.rhel7.1.noarch                                                                                                                         23/53
  Erasing    : python-tempita-0.5.1-6.el7.noarch                                                                                                                                       24/53
  Erasing    : python-itsdangerous-0.23-2.el7.noarch                                                                                                                                   25/53
  Erasing    : python-werkzeug-0.11.11-2.rhel7.noarch                                                                                                                                  26/53
  Erasing    : python-blinker-1.3-2.el7.noarch                                                                                                                                         27/53
  Erasing    : python-dateutil-1.5-7.el7.noarch                                                                                                                                        28/53
  Erasing    : python-editor-0.4-4.el7.noarch                                                                                                                                          29/53
  Erasing    : pgadmin4-python-babel-2.3.4-2.rhel7.1.noarch                                                                                                                            30/53
  Erasing    : python-speaklater-1.3-1.el7.noarch                                                                                                                                      31/53
  Erasing    : pgadmin4-pytz-2018.9-1.rhel7.noarch                                                                                                                                     32/53
  Erasing    : pgadmin4-docs-4.13-1.rhel7.noarch                                                                                                                                       33/53
  Erasing    : pgadmin4-python-Flask-Mail-0.9.1-4.rhel7.1.noarch                                                                                                                       34/53
  Erasing    : 1:pgadmin4-python-backports.csv-1.0.5-3.rhel7.1.noarch                                                                                                                  35/53
  Erasing    : pgadmin4-python-blinker-1.4-3.rhel7.1.noarch                                                                                                                            36/53
  Erasing    : 1:pgadmin4-python-dateutil-2.7.2-1.rhel7.1.noarch                                                                                                                       37/53
  Erasing    : pgadmin4-python-flask-paranoid-0.2-1.rhel7.1.noarch                                                                                                                     38/53
  Erasing    : pgadmin4-python-flask-security-3.0.0-1.rhel7.1.noarch                                                                                                                   39/53
  Erasing    : pgadmin4-python-flask-sqlalchemy-2.3.2-1.rhel7.noarch                                                                                                                   40/53
  Erasing    : pgadmin4-python-flask-wtf-0.14.2-1.rhel7.noarch                                                                                                                         41/53
  Erasing    : pgadmin4-python-passlib-1.7.1-1.rhel7.1.noarch                                                                                                                          42/53
  Erasing    : pgadmin4-python-six-1.12.0-3.rhel7.noarch                                                                                                                               43/53
  Erasing    : pgadmin4-python-sqlparse-0.2.4-1.rhel7.1.noarch                                                                                                                         44/53
  Erasing    : pgadmin4-python-wtforms-2.2.1-1.rhel7.noarch                                                                                                                            45/53
  Erasing    : libtomcrypt-1.17-26.el7.x86_64                                                                                                                                          46/53
  Erasing    : libtommath-0.42.0-6.el7.x86_64                                                                                                                                          47/53
  Erasing    : python-lxml-3.2.1-4.el7.x86_64                                                                                                                                          48/53
  Erasing    : pgadmin4-python-markupsafe-0.23-13.rhel7.1.x86_64                                                                                                                       49/53
  Erasing    : pgadmin4-python-psutil-5.5.1-1.rhel7.x86_64                                                                                                                             50/53
  Erasing    : pgadmin4-python-simplejson-3.16.0-1.rhel7.x86_64                                                                                                                        51/53
  Erasing    : pgadmin4-python-sqlalchemy-1.2.18-1.rhel7.x86_64                                                                                                                        52/53
  Erasing    : python2-psycopg2-2.8.3-3.rhel7.x86_64                                                                                                                                   53/53
  Verifying  : python-speaklater-1.3-1.el7.noarch                                                                                                                                       1/53
  Verifying  : 1:python-flask-0.10.1-4.el7.noarch                                                                                                                                       2/53
  Verifying  : pgadmin4-python-flask-paranoid-0.2-1.rhel7.1.noarch                                                                                                                      3/53
  Verifying  : pgadmin4-python-babel-2.3.4-2.rhel7.1.noarch                                                                                                                             4/53
  Verifying  : pgadmin4-python-flask-sqlalchemy-2.3.2-1.rhel7.noarch                                                                                                                    5/53
  Verifying  : python-itsdangerous-0.23-2.el7.noarch                                                                                                                                    6/53
  Verifying  : python-lxml-3.2.1-4.el7.x86_64                                                                                                                                           7/53
  Verifying  : pgadmin4-python-beautifulsoup4-4.5.1-3.rhel7.1.noarch                                                                                                                    8/53
  Verifying  : python-editor-0.4-4.el7.noarch                                                                                                                                           9/53
  Verifying  : pgadmin4-python-flask-login-0.4.1-1.rhel7.noarch                                                                                                                        10/53
  Verifying  : pgadmin4-python-sshtunnel-0.1.4-1.rhel7.noarch                                                                                                                          11/53
  Verifying  : pgadmin4-python-htmlmin-0.1.12-1.rhel7.1.noarch                                                                                                                         12/53
  Verifying  : python-mako-0.8.1-2.el7.noarch                                                                                                                                          13/53
  Verifying  : pgadmin4-python-alembic-0.9.7-3.rhel7.1.noarch                                                                                                                          14/53
  Verifying  : pgadmin4-python-Flask-Mail-0.9.1-4.rhel7.1.noarch                                                                                                                       15/53
  Verifying  : python-dateutil-1.5-7.el7.noarch                                                                                                                                        16/53
  Verifying  : pgadmin4-python-jinja2-2.8-9.rhel7.1.noarch                                                                                                                             17/53
  Verifying  : python2-crypto-2.6.1-16.el7.x86_64                                                                                                                                      18/53
  Verifying  : pgadmin4-python-sqlalchemy-1.2.18-1.rhel7.x86_64                                                                                                                        19/53
  Verifying  : python2-psycopg2-2.8.3-3.rhel7.x86_64                                                                                                                                   20/53
  Verifying  : pgadmin4-python-psutil-5.5.1-1.rhel7.x86_64                                                                                                                             21/53
  Verifying  : pgadmin4-python-flask-security-3.0.0-1.rhel7.1.noarch                                                                                                                   22/53
  Verifying  : pgadmin4-python-flask-babel-0.11.1-4.rhel7.1.noarch                                                                                                                     23/53
  Verifying  : pgadmin4-docs-4.13-1.rhel7.noarch                                                                                                                                       24/53
  Verifying  : pgadmin4-python-markupsafe-0.23-13.rhel7.1.x86_64                                                                                                                       25/53
  Verifying  : python2-click-6.7-8.el7.noarch                                                                                                                                          26/53
  Verifying  : pgadmin4-python-flask-babelex-0.9.3-1.rhel7.1.noarch                                                                                                                    27/53
  Verifying  : python-paramiko-2.1.1-9.el7.noarch                                                                                                                                      28/53
  Verifying  : python-werkzeug-0.11.11-2.rhel7.noarch                                                                                                                                  29/53
  Verifying  : pgadmin4-python-flask-migrate-2.4.0-1.rhel7.noarch                                                                                                                      30/53
  Verifying  : pgadmin4-pytz-2018.9-1.rhel7.noarch                                                                                                                                     31/53
  Verifying  : python-paste-1.7.5.1-9.20111221hg1498.el7.noarch                                                                                                                        32/53
  Verifying  : pgadmin4-python-simplejson-3.16.0-1.rhel7.x86_64                                                                                                                        33/53
  Verifying  : 1:pgadmin4-python-backports.csv-1.0.5-3.rhel7.1.noarch                                                                                                                  34/53
  Verifying  : libtommath-0.42.0-6.el7.x86_64                                                                                                                                          35/53
  Verifying  : 1:pgadmin4-python-dateutil-2.7.2-1.rhel7.1.noarch                                                                                                                       36/53
  Verifying  : pgadmin4-python-blinker-1.4-3.rhel7.1.noarch                                                                                                                            37/53
  Verifying  : pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch                                                                                                                 38/53
  Verifying  : pgadmin4-python-sqlparse-0.2.4-1.rhel7.1.noarch                                                                                                                         39/53
  Verifying  : pgadmin4-python-six-1.12.0-3.rhel7.noarch                                                                                                                               40/53
  Verifying  : pgadmin4-python-flask-htmlmin-1.5.0-1.rhel7.noarch                                                                                                                      41/53
  Verifying  : pgadmin4-python-itsdangerous-0.24-10.rhel7.1.noarch                                                                                                                     42/53
  Verifying  : pgadmin4-web-4.13-1.rhel7.noarch                                                                                                                                        43/53
  Verifying  : pgadmin4-python-passlib-1.7.1-1.rhel7.1.noarch                                                                                                                          44/53
  Verifying  : python-tempita-0.5.1-6.el7.noarch                                                                                                                                       45/53
  Verifying  : pgadmin4-python-werkzeug-0.15.4-1.rhel7.noarch                                                                                                                          46/53
  Verifying  : pgadmin4-python-flask-gravatar-0.5.0-1.rhel7.1.noarch                                                                                                                   47/53
  Verifying  : python-beaker-1.5.4-10.el7.noarch                                                                                                                                       48/53
  Verifying  : pgadmin4-python-flask-wtf-0.14.2-1.rhel7.noarch                                                                                                                         49/53
  Verifying  : 1:pgadmin4-python-flask-1.0.2-1.rhel7.noarch                                                                                                                            50/53
  Verifying  : pgadmin4-python-wtforms-2.2.1-1.rhel7.noarch                                                                                                                            51/53
  Verifying  : python-blinker-1.3-2.el7.noarch                                                                                                                                         52/53
  Verifying  : libtomcrypt-1.17-26.el7.x86_64                                                                                                                                          53/53

Removed:
  libtomcrypt.x86_64 0:1.17-26.el7                                libtommath.x86_64 0:0.42.0-6.el7                              pgadmin4-docs.noarch 0:4.13-1.rhel7
  pgadmin4-python-Flask-Mail.noarch 0:0.9.1-4.rhel7.1             pgadmin4-python-alembic.noarch 0:0.9.7-3.rhel7.1              pgadmin4-python-babel.noarch 0:2.3.4-2.rhel7.1
  pgadmin4-python-backports.csv.noarch 1:1.0.5-3.rhel7.1          pgadmin4-python-beautifulsoup4.noarch 0:4.5.1-3.rhel7.1       pgadmin4-python-blinker.noarch 0:1.4-3.rhel7.1
  pgadmin4-python-dateutil.noarch 1:2.7.2-1.rhel7.1               pgadmin4-python-flask.noarch 1:1.0.2-1.rhel7                  pgadmin4-python-flask-babel.noarch 0:0.11.1-4.rhel7.1
  pgadmin4-python-flask-babelex.noarch 0:0.9.3-1.rhel7.1          pgadmin4-python-flask-gravatar.noarch 0:0.5.0-1.rhel7.1       pgadmin4-python-flask-htmlmin.noarch 0:1.5.0-1.rhel7
  pgadmin4-python-flask-login.noarch 0:0.4.1-1.rhel7              pgadmin4-python-flask-migrate.noarch 0:2.4.0-1.rhel7          pgadmin4-python-flask-paranoid.noarch 0:0.2-1.rhel7.1
  pgadmin4-python-flask-principal.noarch 0:0.4.0-14.rhel7.1       pgadmin4-python-flask-security.noarch 0:3.0.0-1.rhel7.1       pgadmin4-python-flask-sqlalchemy.noarch 0:2.3.2-1.rhel7
  pgadmin4-python-flask-wtf.noarch 0:0.14.2-1.rhel7               pgadmin4-python-htmlmin.noarch 0:0.1.12-1.rhel7.1             pgadmin4-python-itsdangerous.noarch 0:0.24-10.rhel7.1
  pgadmin4-python-jinja2.noarch 0:2.8-9.rhel7.1                   pgadmin4-python-markupsafe.x86_64 0:0.23-13.rhel7.1           pgadmin4-python-passlib.noarch 0:1.7.1-1.rhel7.1
  pgadmin4-python-psutil.x86_64 0:5.5.1-1.rhel7                   pgadmin4-python-simplejson.x86_64 0:3.16.0-1.rhel7            pgadmin4-python-six.noarch 0:1.12.0-3.rhel7
  pgadmin4-python-sqlalchemy.x86_64 0:1.2.18-1.rhel7              pgadmin4-python-sqlparse.noarch 0:0.2.4-1.rhel7.1             pgadmin4-python-sshtunnel.noarch 0:0.1.4-1.rhel7
  pgadmin4-python-werkzeug.noarch 0:0.15.4-1.rhel7                pgadmin4-python-wtforms.noarch 0:2.2.1-1.rhel7                pgadmin4-pytz.noarch 0:2018.9-1.rhel7
  pgadmin4-web.noarch 0:4.13-1.rhel7                              python-beaker.noarch 0:1.5.4-10.el7                           python-blinker.noarch 0:1.3-2.el7
  python-dateutil.noarch 0:1.5-7.el7                              python-editor.noarch 0:0.4-4.el7                              python-flask.noarch 1:0.10.1-4.el7
  python-itsdangerous.noarch 0:0.23-2.el7                         python-lxml.x86_64 0:3.2.1-4.el7                              python-mako.noarch 0:0.8.1-2.el7
  python-paramiko.noarch 0:2.1.1-9.el7                            python-paste.noarch 0:1.7.5.1-9.20111221hg1498.el7            python-speaklater.noarch 0:1.3-1.el7
  python-tempita.noarch 0:0.5.1-6.el7                             python-werkzeug.noarch 0:0.11.11-2.rhel7                      python2-click.noarch 0:6.7-8.el7
  python2-crypto.x86_64 0:2.6.1-16.el7                            python2-psycopg2.x86_64 0:2.8.3-3.rhel7


Вот и всё. Пакет и все его зависимости удалены.

Если у вас что-то не получается или есть вопросы, пишите в комментариях.

Просьба поделиться статьёй в социальных сетях. Больше ссылок, больше шансов найти эту информацию тем, кому она нужна.
+ 0 -

Добавить комментарий